package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`([^\s=]+)="([^"\\]*(?:\\[\w\W][^"\\]*)*)"`)
var str = `title="Bonjour - \"(le monde))\"" style="color: red;" charset="utf-8" src="monImage.png" alt=""
tes-t6=""`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}