$re = '/([^\s=]+)="([^"\\\\]*(?:\\\\[\w\W][^"\\\\]*)*)"/';
$str = 'title="Bonjour - \\"(le monde))\\"" style="color: red;" charset="utf-8" src="monImage.png" alt=""
tes-t6=""';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);