re = /([^\s=]+)="([^"\\]*(?:\\[\w\W][^"\\]*)*)"/
str = 'title="Bonjour - \\"(le monde))\\"" style="color: red;" charset="utf-8" src="monImage.png" alt=""
tes-t6=""'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end