using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(.*[\/\\])?([\w\-_]*)((?:\.\w+)*)?$";
string input = @"/home/rg-silva/Projects/ITER/COA/sup-python/coabuild_build/test/unit/python-tests_wrapper.sh
/home/rg-silva/Projects/ITER/COA/sup-python/coabuild_build/test/unit/python-tests_wrapper
home/rg-silva/Projects/ITER/COA/sup-python/coabuild_build/test/unit/python-tests_wrapper.sh
home/rg-silva/Projects/ITER/COA/sup-python/coabuild_build/test/unit/python-tests_wrapper.test.sh
home/rg-silva/Projects/ITER/COA/sup-python/coabuild_build/test/unit/python-tests_wrapper
python-tests_wrapper.sh
python-tests_wrapper
./home/rg-silva/Projects/ITER/COA/sup-python/coabuild_build/test/unit/python-tests_wrapper
python-tests_wrapper
python-tests_wrapper.test.sh
./home/rg-silva/Projects/ITER/COA/sup-python/coabuild_build/test/unit/python-tests_wrapper.
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}