use strict;
my $str = '/home/rg-silva/Projects/ITER/COA/sup-python/coabuild_build/test/unit/python-tests_wrapper.sh
/home/rg-silva/Projects/ITER/COA/sup-python/coabuild_build/test/unit/python-tests_wrapper
home/rg-silva/Projects/ITER/COA/sup-python/coabuild_build/test/unit/python-tests_wrapper.sh
home/rg-silva/Projects/ITER/COA/sup-python/coabuild_build/test/unit/python-tests_wrapper.test.sh
home/rg-silva/Projects/ITER/COA/sup-python/coabuild_build/test/unit/python-tests_wrapper
python-tests_wrapper.sh
python-tests_wrapper
./home/rg-silva/Projects/ITER/COA/sup-python/coabuild_build/test/unit/python-tests_wrapper
python-tests_wrapper
python-tests_wrapper.test.sh
./home/rg-silva/Projects/ITER/COA/sup-python/coabuild_build/test/unit/python-tests_wrapper.
';
my $regex = qr/^(.*[\/\\])?([\w\-_]*)((?:\.\w+)*)?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}