const regex = /^(.*[\/\\])?([\w\-_]*)((?:\.\w+)*)?$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(.*[\\\/\\\\])?([\\w\\-_]*)((?:\\.\\w+)*)?$', 'gm')
const str = `/home/rg-silva/Projects/ITER/COA/sup-python/coabuild_build/test/unit/python-tests_wrapper.sh
/home/rg-silva/Projects/ITER/COA/sup-python/coabuild_build/test/unit/python-tests_wrapper
home/rg-silva/Projects/ITER/COA/sup-python/coabuild_build/test/unit/python-tests_wrapper.sh
home/rg-silva/Projects/ITER/COA/sup-python/coabuild_build/test/unit/python-tests_wrapper.test.sh
home/rg-silva/Projects/ITER/COA/sup-python/coabuild_build/test/unit/python-tests_wrapper
python-tests_wrapper.sh
python-tests_wrapper
./home/rg-silva/Projects/ITER/COA/sup-python/coabuild_build/test/unit/python-tests_wrapper
python-tests_wrapper
python-tests_wrapper.test.sh
./home/rg-silva/Projects/ITER/COA/sup-python/coabuild_build/test/unit/python-tests_wrapper.
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}