$re = '/^(.*[\/\\\\])?([\w\-_]*)((?:\.\w+)*)?$/m';
$str = '/home/rg-silva/Projects/ITER/COA/sup-python/coabuild_build/test/unit/python-tests_wrapper.sh
/home/rg-silva/Projects/ITER/COA/sup-python/coabuild_build/test/unit/python-tests_wrapper
home/rg-silva/Projects/ITER/COA/sup-python/coabuild_build/test/unit/python-tests_wrapper.sh
home/rg-silva/Projects/ITER/COA/sup-python/coabuild_build/test/unit/python-tests_wrapper.test.sh
home/rg-silva/Projects/ITER/COA/sup-python/coabuild_build/test/unit/python-tests_wrapper
python-tests_wrapper.sh
python-tests_wrapper
./home/rg-silva/Projects/ITER/COA/sup-python/coabuild_build/test/unit/python-tests_wrapper
python-tests_wrapper
python-tests_wrapper.test.sh
./home/rg-silva/Projects/ITER/COA/sup-python/coabuild_build/test/unit/python-tests_wrapper.
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);