#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=.*\bApple\b)(?=.*\bCar\b)(?=.*\bBat\b)(?!.*(?:,|^)(?:(?!\b(?:Apple|Bat|Car)\b).)+(?:,|$))^.*$"
Local $sString = "Bat, Car, Apple" & @CRLF & _
"Other, Bat, Car, Apple" & @CRLF & _
"Car, Bat, Apple" & @CRLF & _
"Car, Other, Bat, Apple" & @CRLF & _
"Apple, Car, Bat" & @CRLF & _
"Apple, Car, Bat, Stick" & @CRLF & _
"Bat, Car" & @CRLF & _
"Apple" & @CRLF & _
"Car, Apple, Bat" & @CRLF & _
"Cartography, Apple, Bat, Car"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")