re = /(?=.*\bApple\b)(?=.*\bCar\b)(?=.*\bBat\b)(?!.*(?:,|^)(?:(?!\b(?:Apple|Bat|Car)\b).)+(?:,|$))^.*$/m
str = 'Bat, Car, Apple
Other, Bat, Car, Apple
Car, Bat, Apple
Car, Other, Bat, Apple
Apple, Car, Bat
Apple, Car, Bat, Stick
Bat, Car
Apple
Car, Apple, Bat
Cartography, Apple, Bat, Car'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end