import Foundation
let pattern = #"(?=.*\bApple\b)(?=.*\bCar\b)(?=.*\bBat\b)(?!.*(?:,|^)(?:(?!\b(?:Apple|Bat|Car)\b).)+(?:,|$))^.*$"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Bat, Car, Apple
Other, Bat, Car, Apple
Car, Bat, Apple
Car, Other, Bat, Apple
Apple, Car, Bat
Apple, Car, Bat, Stick
Bat, Car
Apple
Car, Apple, Bat
Cartography, Apple, Bat, Car
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)