using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=.*\bApple\b)(?=.*\bCar\b)(?=.*\bBat\b)(?!.*(?:,|^)(?:(?!\b(?:Apple|Bat|Car)\b).)+(?:,|$))^.*$";
string input = @"Bat, Car, Apple
Other, Bat, Car, Apple
Car, Bat, Apple
Car, Other, Bat, Apple
Apple, Car, Bat
Apple, Car, Bat, Stick
Bat, Car
Apple
Car, Apple, Bat
Cartography, Apple, Bat, Car";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}