import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?=.*\\bApple\\b)(?=.*\\bCar\\b)(?=.*\\bBat\\b)(?!.*(?:,|^)(?:(?!\\b(?:Apple|Bat|Car)\\b).)+(?:,|$))^.*$";
final String string = "Bat, Car, Apple\n"
+ "Other, Bat, Car, Apple\n"
+ "Car, Bat, Apple\n"
+ "Car, Other, Bat, Apple\n"
+ "Apple, Car, Bat\n"
+ "Apple, Car, Bat, Stick\n"
+ "Bat, Car\n"
+ "Apple\n"
+ "Car, Apple, Bat\n"
+ "Cartography, Apple, Bat, Car";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}