using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"href=""([^""]+)""[^>]*?>[^<]*?skirt[^<]*?<";
string input = @"<a href=""/clothing/jacket/"">Jacket</a>
<a href=""/clothing/Socks/"">Socks</a>
<a href=""/clothing/Shoes/"">Shoes</a>
<a href=""/clothing/xx_Sk0rt/"" class=""xxx"">test Skirt test</a>";
RegexOptions options = RegexOptions.IgnoreCase | RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}