import re
regex = re.compile(r"href=\"([^\"]+)\"[^>]*?>[^<]*?skirt[^<]*?<", flags=re.IGNORECASE | re.MULTILINE)
test_str = ("<a href=\"/clothing/jacket/\">Jacket</a>\n"
"<a href=\"/clothing/Socks/\">Socks</a>\n"
"<a href=\"/clothing/Shoes/\">Shoes</a>\n"
"<a href=\"/clothing/xx_Sk0rt/\" class=\"xxx\">test Skirt test</a>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")