$re = '/href="([^"]+)"[^>]*?>[^<]*?skirt[^<]*?</im';
$str = '<a href="/clothing/jacket/">Jacket</a>
<a href="/clothing/Socks/">Socks</a>
<a href="/clothing/Shoes/">Shoes</a>
<a href="/clothing/xx_Sk0rt/" class="xxx">test Skirt test</a>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);