re = /href="([^"]+)"[^>]*?>[^<]*?skirt[^<]*?</im
str = '<a href="/clothing/jacket/">Jacket</a>
<a href="/clothing/Socks/">Socks</a>
<a href="/clothing/Shoes/">Shoes</a>
<a href="/clothing/xx_Sk0rt/" class="xxx">test Skirt test</a>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end