#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:([A-Z]),(?!\1))*[A-Z]$"
Local $sString = "A,B" & @CRLF & _
"A,B,C,D,E,F" & @CRLF & _
"D,A,D" & @CRLF & _
"A" & @CRLF & _
"D,D,A" & @CRLF & _
",B,C" & @CRLF & _
"B,C," & @CRLF & _
"A,,B,C" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")