$re = '/^(?:([A-Z]),(?!\1))*[A-Z]$/m';
$str = 'A,B
A,B,C,D,E,F
D,A,D
A
D,D,A
,B,C
B,C,
A,,B,C
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);