import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:([A-Z]),(?!\\1))*[A-Z]$";
final String string = "A,B\n"
+ "A,B,C,D,E,F\n"
+ "D,A,D\n"
+ "A\n"
+ "D,D,A\n"
+ ",B,C\n"
+ "B,C,\n"
+ "A,,B,C\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}