import re
regex = re.compile(r"^(?:([A-Z]),(?!\1))*[A-Z]$", flags=re.MULTILINE)
test_str = ("A,B\n"
"A,B,C,D,E,F\n"
"D,A,D\n"
"A\n"
"D,D,A\n"
",B,C\n"
"B,C,\n"
"A,,B,C\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")