re = /^(?:([A-Z]),(?!\1))*[A-Z]$/m
str = 'A,B
A,B,C,D,E,F
D,A,D
A
D,D,A
,B,C
B,C,
A,,B,C
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end