using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\b[a-z0-9]{6}\b";
string input = @"abcdef abc 987 hello1 123456 abcde abcdefg 1234567 fedcba";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}