$re = '/\b[a-z0-9]{6}\b/';
$str = 'abcdef abc 987 hello1 123456 abcde abcdefg 1234567 fedcba';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);