const regex = /\b[a-z0-9]{6}\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b[a-z0-9]{6}\\b', 'g')
const str = `abcdef abc 987 hello1 123456 abcde abcdefg 1234567 fedcba`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}