package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\b[a-z0-9]{6}\b`)
var str = `abcdef abc 987 hello1 123456 abcde abcdefg 1234567 fedcba`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}