package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\A((https?:\/\/(localhost:3000|blog\.example\.com))?\/posts\/(?<post_id>\S+?))?(?<fragment>#(comment-(?<comment_id>\d+)|\S+?)?)?\z`)
var str = `http://blog.example.com/posts/foo#comment-123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}