re = /\A((https?:\/\/(localhost:3000|blog\.example\.com))?\/posts\/(?<post_id>\S+?))?(?<fragment>#(comment-(?<comment_id>\d+)|\S+?)?)?\z/m
str = 'http://blog.example.com/posts/foo#comment-123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end