const regex = /\A((https?:\/\/(localhost:3000|blog\.example\.com))?\/posts\/(?<post_id>\S+?))?(?<fragment>#(comment-(?<comment_id>\d+)|\S+?)?)?\z/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\A((https?:\\\/\\\/(localhost:3000|blog\\.example\\.com))?\\\/posts\\\/(?<post_id>\\S+?))?(?<fragment>#(comment-(?<comment_id>\\d+)|\\S+?)?)?\\z', 'gm')
const str = `http://blog.example.com/posts/foo#comment-123`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}