import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\A((https?:\\/\\/(localhost:3000|blog\\.example\\.com))?\\/posts\\/(?<post_id>\\S+?))?(?<fragment>#(comment-(?<comment_id>\\d+)|\\S+?)?)?\\z";
final String string = "http://blog.example.com/posts/foo#comment-123";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}