#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[?&]checkedby:.+"
Local $sString = "http://toto.com:8080/get.php?username=toto&password=toto&checkedby:titi.com" & @CRLF & _
"http://toto.com/1234/4321/5678?checkedby:anyone.xyz" & @CRLF & _
"http://toto.com/1234/4321/5678?master.m3u8&checkedby:anyelse.to" & @CRLF & _
"http://toto.com:8080/get.php?username=toto&password=toto&type=output.ext?checkedby:titi.com"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)