use strict;
my $str = 'http://toto.com:8080/get.php?username=toto&password=toto&checkedby:titi.com
http://toto.com/1234/4321/5678?checkedby:anyone.xyz
http://toto.com/1234/4321/5678?master.m3u8&checkedby:anyelse.to
http://toto.com:8080/get.php?username=toto&password=toto&type=output.ext?checkedby:titi.com';
my $regex = qr/[?&]checkedby:.+/p;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";