import Foundation
let pattern = #"[?&]checkedby:.+"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
http://toto.com:8080/get.php?username=toto&password=toto&checkedby:titi.com
http://toto.com/1234/4321/5678?checkedby:anyone.xyz
http://toto.com/1234/4321/5678?master.m3u8&checkedby:anyelse.to
http://toto.com:8080/get.php?username=toto&password=toto&type=output.ext?checkedby:titi.com
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)