using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[?&]checkedby:.+";
string substitution = @"";
string input = @"http://toto.com:8080/get.php?username=toto&password=toto&checkedby:titi.com
http://toto.com/1234/4321/5678?checkedby:anyone.xyz
http://toto.com/1234/4321/5678?master.m3u8&checkedby:anyelse.to
http://toto.com:8080/get.php?username=toto&password=toto&type=output.ext?checkedby:titi.com";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}