import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "[?&]checkedby:.+";
final String string = "http://toto.com:8080/get.php?username=toto&password=toto&checkedby:titi.com\n"
+ "http://toto.com/1234/4321/5678?checkedby:anyone.xyz\n"
+ "http://toto.com/1234/4321/5678?master.m3u8&checkedby:anyelse.to\n"
+ "http://toto.com:8080/get.php?username=toto&password=toto&type=output.ext?checkedby:titi.com";
final String subst = "";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}