import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\B\\$\\b([^$]*)\\b\\$\\B";
final String string = "The price is between $400 and $500.\n"
+ "The price is between $400$ and $500$.\n"
+ "The price is between $old_value$ and $new_value$.";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}