const regex = /\B\$\b([^$]*)\b\$\B/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\B\\$\\b([^$]*)\\b\\$\\B', 'g')
const str = `The price is between \$400 and \$500.
The price is between \$400\$ and \$500\$.
The price is between \$old_value\$ and \$new_value\$.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}