// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\B\$\b([^$]*)\b\$\B").unwrap();
let string = "The price is between $400 and $500.
The price is between $400$ and $500$.
The price is between $old_value$ and $new_value$.";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}