re = /\B\$\b([^$]*)\b\$\B/
str = 'The price is between $400 and $500.
The price is between $400$ and $500$.
The price is between $old_value$ and $new_value$.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end