$re = '/\B\$\b([^$]*)\b\$\B/';
$str = 'The price is between $400 and $500.
The price is between $400$ and $500$.
The price is between $old_value$ and $new_value$.';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);