#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)=("?)\{([^}]+)\}\1"
Local $sString = "={abc}" & @CRLF & _
"="{cde}" & @CRLF & _
"="{qwe}"" & @CRLF & _
"={123}"" & @CRLF & _
"={098" & @CRLF & _
"=777" & @CRLF & _
"=434 "
Local $sSubst = "\2"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)