use strict;
my $str = '={abc}
="{cde}
="{qwe}"
={123}"
={098
=777
=434 ';
my $regex = qr/=("?)\{([^}]+)\}\1/mp;
my $subst = '\\2';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";