re = /=("?)\{([^}]+)\}\1/m
str = '={abc}
="{cde}
="{qwe}"
={123}"
={098
=777
=434 '
subst = '\\2'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result