import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "=(\"?)\\{([^\\}]+)\\}\\1";
final String string = "={abc}\n"
+ "=\"{cde}\n"
+ "=\"{qwe}\"\n"
+ "={123}\"\n"
+ "={098\n"
+ "=777\n"
+ "=434 ";
final String subst = "\\2";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}