$re = '/=("?)\{([^}]+)\}\1/m';
$str = '={abc}
="{cde}
="{qwe}"
={123}"
={098
=777
=434 ';
$subst = "\2";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;