#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mi)^\d{4}\.\d{2}\.\d{2} \S.*(?:\r?\n\d{4}\.\d{2}\.\d{2}\b.*)+(?:\r?\n(?!\d{4}\.\d{2}\.\d{2}\b).*)*"
Local $sString = "2020.11.01 SOME TEXT -17,30 83 016,86" & @CRLF & _
"2020.10.30" & @CRLF & _
"2020.10.30" & @CRLF & _
"2020.10.30" & @CRLF & _
"2020.10.30" & @CRLF & _
"Some text that should be" & @CRLF & _
"matched 20.01.2020 as" & @CRLF & _
"multiline text" & @CRLF & _
"until now" & @CRLF & _
"2020.11.01 SOME TEXT -27,30 81 016,86" & @CRLF & _
"2020.10.30" & @CRLF & _
"Some text that should be" & @CRLF & _
"matched 20.01.2020 as" & @CRLF & _
"multiline text" & @CRLF & _
"until now" & @CRLF & _
"" & @CRLF & _
"2020.10.30"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")