re = /^\d{4}\.\d{2}\.\d{2} \S.*(?:\r?\n\d{4}\.\d{2}\.\d{2}\b.*)+(?:\r?\n(?!\d{4}\.\d{2}\.\d{2}\b).*)*/mi
str = '2020.11.01 SOME TEXT -17,30 83 016,86
2020.10.30
2020.10.30
2020.10.30
2020.10.30
Some text that should be
matched 20.01.2020 as
multiline text
until now
2020.11.01 SOME TEXT -27,30 81 016,86
2020.10.30
Some text that should be
matched 20.01.2020 as
multiline text
until now
2020.10.30'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end