import re
regex = re.compile(r"^\d{4}\.\d{2}\.\d{2} \S.*(?:\r?\n\d{4}\.\d{2}\.\d{2}\b.*)+(?:\r?\n(?!\d{4}\.\d{2}\.\d{2}\b).*)*", flags=re.MULTILINE | re.IGNORECASE)
test_str = ("2020.11.01 SOME TEXT -17,30 83 016,86\n"
"2020.10.30\n"
"2020.10.30\n"
"2020.10.30\n"
"2020.10.30\n"
"Some text that should be\n"
"matched 20.01.2020 as\n"
"multiline text\n"
"until now\n"
"2020.11.01 SOME TEXT -27,30 81 016,86\n"
"2020.10.30\n"
"Some text that should be\n"
"matched 20.01.2020 as\n"
"multiline text\n"
"until now\n\n"
"2020.10.30")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")