const regex = /^\d{4}\.\d{2}\.\d{2} \S.*(?:\r?\n\d{4}\.\d{2}\.\d{2}\b.*)+(?:\r?\n(?!\d{4}\.\d{2}\.\d{2}\b).*)*/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\d{4}\\.\\d{2}\\.\\d{2} \\S.*(?:\\r?\\n\\d{4}\\.\\d{2}\\.\\d{2}\\b.*)+(?:\\r?\\n(?!\\d{4}\\.\\d{2}\\.\\d{2}\\b).*)*', 'gmi')
const str = `2020.11.01 SOME TEXT -17,30 83 016,86
2020.10.30
2020.10.30
2020.10.30
2020.10.30
Some text that should be
matched 20.01.2020 as
multiline text
until now
2020.11.01 SOME TEXT -27,30 81 016,86
2020.10.30
Some text that should be
matched 20.01.2020 as
multiline text
until now
2020.10.30`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}