import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d{4}\\.\\d{2}\\.\\d{2} \\S.*(?:\\r?\\n\\d{4}\\.\\d{2}\\.\\d{2}\\b.*)+(?:\\r?\\n(?!\\d{4}\\.\\d{2}\\.\\d{2}\\b).*)*";
final String string = "2020.11.01 SOME TEXT -17,30 83 016,86\n"
+ "2020.10.30\n"
+ "2020.10.30\n"
+ "2020.10.30\n"
+ "2020.10.30\n"
+ "Some text that should be\n"
+ "matched 20.01.2020 as\n"
+ "multiline text\n"
+ "until now\n"
+ "2020.11.01 SOME TEXT -27,30 81 016,86\n"
+ "2020.10.30\n"
+ "Some text that should be\n"
+ "matched 20.01.2020 as\n"
+ "multiline text\n"
+ "until now\n\n"
+ "2020.10.30";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}