# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/[a-z](?=[A-Z])|[A-Z](?=[A-Z][a-z])/\g<0> /gm;t' <<< "CollectibleOpen-WorldVirtual-World
BreedingCardPVP
Auto-BattlerBreedingStrategy
MinigameOpen-WorldVirtual-World
ActionSimulationSports
AdventureMMOStrategy
AdventureCasualPuzzle
Sports
CollectibleSci-FiVirtual-World
Battle-RoyaleeSportsMOBA
ActionPVPShooter
PVPSci-FiTower-Defense
ActionBattle-Royale
PVPSci-FiShooter
BreedingCollectibleMining
CollectibleDeFieSports
ActionAdventureShooter
City-BuildingCollectibleSimulation
ActionStrategy
AdventureOpen-World
BreedingRacingSports
Open-WorldVirtual-World
CollectibleIdle
ActionAdventure
CardCollectiblePVP
Battle-RoyaleFantasyMOBA
City-Building
BuildingMMOStrategy
AdventureMMORPG
ActionAdventureIdle
MOBARPGStrategy
MMORPGStrategy
CardCollectibleIdle
Open-WorldPVPRPG
DeFiMMOSpace
Collectible
CardCollectiblePVP
Auto-BattlerDeFiRPG
AdventureMMOOpen-World
CollectibleOpen-WorldVirtual-World
CollectibleIdleRPG
CardCollectiblePVP
ActionAdventurePVP
Sci-FiShooterSurvival
ActionStrategy
ArcadeMinigame
BreedingPVPRacing
MOBAPVP
ActionSports
PVPSpaceTurn-based
MMOStrategyTower-Defense"